Установка версии 3.0

при попытке установить возникла проблема.

план установки


  • Выбранные параметры установки:

  • Установка в папку: C:Program FilesLERS
  • Устанавливаемые компоненты:
    Общие файлы;
    Служба обновления;
    Сервер;
    Рабочее место оператора;
    Служба опроса;
    Веб-интерфейс;

- В домене TKG создаются учётные записи:
LersServerAccount
LersWebAccount
LersUpdaterAccount


\

  • База данных:
    Создаётся новая

  • Адрес и порт сервера приложений:
    localhost:10000

  • Источник обновлений:
    Серверы ХЦЭС

  • Установка обновлений всеми пользователями:
    разрешена

  • Дополнительные задачи:
    База данных LERS
    Добавить порт сервера в исключения брандмауэра Windows
    Создать ярлыки на рабочем столе

  • Веб-интерфейс устанавливается на порт: 80

и ошибка -
2012-07-18_170724.jpg
Вопрос: как устанавливать?
локальные админские права есть
машина в домене, да, но почему пытается добавить доменных пользователей а не локальных?

итак, установить удалось, отключившись от сети, т.е. от домена, в локальном режиме. но!
при попытке запуска клиентского приложения и входа в систему выскакивает ошибка -
2012-07-18_181151.jpg
смотрим лог клиента -
18-07-2012 18:11:07.787 D Создание сокета… LERS.Common.Connection
18-07-2012 18:11:07.787 D Подключение к серверу localhost:10000 LERS.Common.Connection
18-07-2012 18:11:07.798 I Соединение установлено. LERS.Common.Connection
18-07-2012 18:11:07.798 D Локальный IP-адрес: 192.168.34.140 LERS.Common.Connection
18-07-2012 18:11:07.798 D Отправка запроса на авторизацию… LERS.Common.Connection
18-07-2012 18:11:07.798 D Отправка запроса на операцию #LOGIN (Подключение к серверу) LERS.Common.Connection
18-07-2012 18:11:07.798 D Отправка запроса LOGIN (RId = 1). Размер пакета: 115.
18-07-2012 18:11:07.799 D Отправлены данные размером 115 байт. LERS.Common.Connection
18-07-2012 18:11:28.078 D Отправка запроса CANCEL_REQUEST (RId = -1). Размер пакета: 65.
18-07-2012 18:11:28.080 D Отправлены данные размером 65 байт. LERS.Common.Connection
18-07-2012 18:11:28.081 D Отключение от сервера… LERS.Common.Connection
18-07-2012 18:11:28.081 D Произведено отключение от сервера. LERS.Common.Connectionсмотрим лог сервера -
2012-07-18 18:11:10.815 E:2960 Ошибка подключения к базе данных LERS на сервере 127.0.0.1. Login failed. The login is from an untrusted domain and cannot be used with Windows authentication. LERS.WorkerThreadContext
2012-07-18 18:11:20.818 E:2960 Ошибка подключения к базе данных LERS на сервере 127.0.0.1. Login failed. The login is from an untrusted domain and cannot be used with Windows authentication. LERS.WorkerThreadContextчаво делать?, см. мой пост выше, там при установке была задана не windows authentication.

upd: посмотрел на сервер SQL - висит открытая сессия с базой, от имени sa :du_ma_et: …

Пришлите пожалуйста файл lers_install.log из папки %temp%.

ушло на support@lers.ru

пока нету…

Скажите, устанавливали на рабочую станцию, сервер или контроллер домена?
SQL-сервер установлен локально / на другом компьютере? Если на другом, то входит ли тот, другой, в домен?

рабочая станция, SQL локально.
lers_install_log.log (502 KB)

Спасибо, будем изучать…

При указании в качестве имени SQL-сервера 127.0.0.1 программа наша установки посчитала его не локальным, это привело к ряду последующих ошибок в установке. Если не затруднит - удалите систему и установите заново, с указанием имени SQL-сервера (local).

ok, сейчас попробую

спасибо, заработало :bra_vo:
будем знакомиться и задавать новые вопросы.

Отпишусь ещё по одной встреченной проблеме, может кому пригодится. или исправится :slight_smile:
устанавливал версию 3.0 “с нуля” на winserver 2003. в процессе установки “застрял” на моменте после ввода номера порта web-службы
в лог установки пишет такое -

2012-07-23 16:57:37.484 I:1004 Порт веб-интефрейса: 80
2012-07-23 16:57:37.484 I:1004 Проверяем, доступен ли порт 80 на IIS v6
2012-07-23 16:57:37.484 I:1004 Запрашиваем список сайтов IIS 6
2012-07-23 16:57:37.484 I:1004 Команда получения списка сайтов: cscript /nologo “C:DOCUME~1ADMINI~1LOCALS~1Temp1RarSFX0schemasite_list_iis6.js”

и окно установки перестаёт отвечать, виснет намертво. пришлось убить.
решилось после просмотра скрипта site_list_iis6.js и взгляда в конфиг IIS 6
оказалось, в конфиге IIS нет ни одного “сайта”. думаю, в скрипте проверки нужно обработать данное исключение.
после добавления пустого конфига в IIS всё установилось без проблем.

Спасибо, учтем.

и ещё одна бяка вылезла легко решившаяся, на том же сервере не запускалась веб-морда. 404 выпуливала.
как оказалась не была разрешена ASP.NET 4.0… включил разрешение вручную - заработало.
может потому что не ребутился после установки фреймворка…

Благодарим за замечания. Мы внесли соответствующие изменения в программу установки.