Страница 1 из 1

Ошибка авторизации через web-api после обновления до 3.35.1 [8993]

Добавлено: 07 июл 2020, 11:09
mk12
Здравствуйте. Через web api получаем данные в сводную таблицу в excel. После обновления до 3.35.1 (до этого была версия 3.34.7) на этапе авторизации возникает ошибка (на скриншоте). Из-за чего она может возникать?

Re: Ошибка авторизации через web-api после обновления до 3.35.1

Добавлено: 07 июл 2020, 11:18
Иван Славный
Подобная ситуация уже рассматривалась в другой теме, правда в проекте по Lers Framework, но думаю причины ее возникновения такие же. Выполните приведенные в этой теме рекомендации. Это должно решить проблему и в вашем случае.

Re: Ошибка авторизации через web-api после обновления до 3.35.1

Добавлено: 13 июл 2020, 15:08
mk12
В тех темах обсуждаются проекты в которые можно как-то добавить библиотеки. Нам это не подойдет т.к. весь код у нас в тех же файлах xls на vba.
А действия, описанные на странице, выполняемые для совместимости со старым REST API нужно ли выполнять для работы Веб-сервиса доступа к данным? Может дело в этом?

Re: Ошибка авторизации через web-api после обновления до 3.35.1 [8993]

Добавлено: 14 июл 2020, 08:18
Иван Славный
Мы протестировали работу старого Веб-сервиса доступа к данным. Действительно при авторизации наблюдается указанная вами ошибка. Мы исправим ее в следующей версии.

Нет, данная ошибка никак не связана с невыполнением действий по настройке в статье, ссылку на которую вы приложили. Повторюсь, данная ошибка наблюдается непосредственно в Веб-сервисе доступа к данным.

Также хочу отметить, что в новой версии ЛЭРС УЧЕТ появился новый REST API, относящийся непосредственно к Серверу ЛЭРС УЧЕТ. Сейчас в нем не так много функций, но он постепенно наполняется ими. Вы можете начать разработку на основе данного API, так как в последствии устаревшие API (REST API и Веб-сервис доступа к данным, который вы как раз намереваетесь использовать) будут упразднены и удалены из ЛЭРС УЧЕТ. В случае, если вам понадобится какая либо функция, которой еще нет в API, вы можете запросить ее, создав отдельную тему в данном разделе.

Re: Ошибка авторизации через web-api после обновления до 3.35.1 [8993]

Добавлено: 16 июл 2020, 10:18
diego
Иван Славный писал(а):
14 июл 2020, 08:18
Действительно при авторизации наблюдается указанная вами ошибка. Мы исправим ее в следующей версии.
Добрый день! Прошу уточнить ведуться ли работы по устранению выше указанной ошибки?

И в какой версии будет исправление.

Re: Ошибка авторизации через web-api после обновления до 3.35.1 [8993]

Добавлено: 16 июл 2020, 10:55
Иван Славный
Да, работы еще ведутся. Предварительно окончание работ запланировано на следующую версию 3.36.

Re: Ошибка авторизации через web-api после обновления до 3.35.1 [8993]

Добавлено: 16 июл 2020, 13:02
diego
Иван Славный писал(а):
16 июл 2020, 10:55
Да, работы еще ведутся. Предварительно окончание работ запланировано на следующую версию 3.36.
Антон Чичков писал(а):
23 дек 2019, 04:57
Мы планируем завершить основной объём работ по миграции в версии 3.35, после чего начнётся планомерная работа по миграции функционала и развитию нового сервера. В версии 3.36 - 3.37 планируется заморозка существующего WEB-интерфейса и слияние его функционала с основным сервером ЛЭРС УЧЁТ.
Как я понимаю из планов работ по развитию сервера ЛЭРС в версии 3.36 мы можем не увидеть api старого web интерфейса.

Возможно ли исправление ошибки с авторизацией до выхода версии 3.36?

Или может есть альтернативные варианты решения вопроса с авторизацией?

Re: Ошибка авторизации через web-api после обновления до 3.35.1 [8993]

Добавлено: 16 июл 2020, 14:51
diprime
Иван Славный писал(а):
16 июл 2020, 10:55
Да, работы еще ведутся. Предварительно окончание работ запланировано на следующую версию 3.36.
Это очень грустная новость...

Уважаемые разработчики!
При всех возможных обстоятельствах необходимо выпустить хотфикс, решающий проблему авторизации в старом web-сервисе. Старый API не работает, в новом REST API, как выяснилось, нет некоторого функционала, существующего в старом. Время идёт, через два дня закрытие месяца, мы - разработчики сопутствующего ПО - оказались в безвыходной ситуации...

Re: Ошибка авторизации через web-api после обновления до 3.35.1 [8993]

Добавлено: 17 июл 2020, 06:10
Иван Славный
Я передал ваши пожелания нашим разработчикам. Мы приняли решение перенести исправление данной ошибки на следующее обновление 3.35.4.

Re: Ошибка авторизации через web-api после обновления до 3.35.1 [8993]

Добавлено: 23 июл 2020, 07:56
diprime
Подскажите, пожалуйста, какие планируемые сроки выхода обновления 3.35.4?

Re: Ошибка авторизации через web-api после обновления до 3.35.1 [8993]

Добавлено: 23 июл 2020, 09:08
Константин Коротких
Мы планируем выпустить обновление 3.35.4 на следующей неделе.

Re: Ошибка авторизации через web-api после обновления до 3.35.1 [8993]

Добавлено: 10 авг 2020, 16:07
mk12
Здравствуйте. Не вижу на форуме информации о выходе 3.35.4, но уже выпущена 3.36.0. Подскажите, в ней исправлена эта ошибка?

Re: Ошибка авторизации через web-api после обновления до 3.35.1 [8993]

Добавлено: 11 авг 2020, 03:43
Иван Славный
Да, все верно. Все изменения, которые планировалось выпустить в версии 3.35.4, были перенесены в версию 3.36.0.