Ошибка при опросе СПГ741,742, нет ответа от прибора

Вопросы по настройке опроса и проблемам с подключением или чтением данных

Модератор: Модераторы

MAKS18
Сообщения: 400
Зарегистрирован: 17 май 2016, 10:51

Re: Ошибка при опросе СПГ741,742, нет ответа от прибора

Сообщение MAKS18 » 23 ноя 2016, 05:10

Можно же сделать дополнительный драйвер спг742 Стел-турбо. Все остальные корректоры работают в прозрачном режиме. Это особенность самого Стел-турбо, в чем сложность?
Аватара пользователя
Константин Коротких
Разработчик
Разработчик
Сообщения: 6340
Зарегистрирован: 01 сен 2015, 08:29

Re: Ошибка при опросе СПГ741,742, нет ответа от прибора

Сообщение Константин Коротких » 23 ноя 2016, 05:55

Корректоры работаю не в прозрачном режиме, а по своему протоколу. В прозрачном режиме может работать модем (контроллер). Данные 01 01 01 01 относятся не к корректору, а к СТЕЛ-Турбо, на что указывает, что без них он не работает, а также говорит о том, что работает он не в прозрачном режиме.
Добавление второго драйвера спг742 Стел-турбо является не корректным, поскольку у пользователей возникнут вопросы, увеличится количество обращений в службу поддержки. Необходимо добавлять драйвер СТЕЛ-Турбо, однако у нас нет описания протокола обмена, как вы знаете, поэтому добавить его мы не можем. Мы не можем добавить драйвер СТЕЛ-Турбо с данными 01 01 01 01, еще потому, что если какой-то другой пользователь воспользуется им и он не будет работать, то мы не сможем объяснить почему опрос не идет. Для прибора СТЕЛ-Турбо с другими настройками эти 4 байта могут иметь другое значение.
Мы не можем добавить в систему поддержку прибора не зная как он работает.
MAKS18
Сообщения: 400
Зарегистрирован: 17 май 2016, 10:51

Re: Ошибка при опросе СПГ741,742, нет ответа от прибора

Сообщение MAKS18 » 23 ноя 2016, 06:09

1) Я и имел ввиду Стел-турбо. Цитирую акцент " Стел-турбо работает в прозрачном режиме, но опрос работает странно( у них был протокол от стела, они его получили официально)
2) настройки и для спг 741 и 742 в Стел-турбо одинаковые, при настройке Стел-турбо на эти два корректора выбирается спг 741. Если с 741 работает в прозрачном режиме, как можно утверждать что с 742 не в прозрачном? И при этом работают другие корректоры?
2) какие возникнут вопросы у пользователей если чётко указанно что драйвер для спг- Стел-турбо, я не понимаю.
3) с 4 мя корректорами Стел-турбо работает в прозрачном режиме, поэтому добавлять Стел-турбо нет смысла. Данные 01 01 01 01 только для открытия связи и любые настройки Стел-турбо не влияют на них, они всегда 01 01 01 01. Если производитель ответит что "да, 01 01 01 01, это особенность работы с спг742" это будет достаточно для добавления Стел-турбо? Дело только в официальном мнение завода изготовителя? Есть не официальное мнение от акцента.
4) вы хотябы можете проверить опрос объектов с 01 01 01 01, чтобы мы на 100% знали что дело именно в них. Контакты я скидывал на почту.
MAKS18
Сообщения: 400
Зарегистрирован: 17 май 2016, 10:51

Re: Ошибка при опросе СПГ741,742, нет ответа от прибора

Сообщение MAKS18 » 23 ноя 2016, 16:22

Давайте я более подробно отвечу.

1) Конечно я имел ввиду что СТЕЛ_ТУРБО работает в прозрачном режиме, а не корректоры. Это доказывает ответ пр. "АКЦЕНТ", с их оборудованием работает вся белгородская область и говорить что они не разбираются в том что говорят абсурд. Они получали протокол от СТЕЛ, полное описание, и они утверждают что "ПРОТОКОЛ ОПРОСА ОБОРУДОВАНИЯ ЧЕРЕЗ СТЕЛ ПРОЗРАЧНЫЙ"(они это не придумали от себя). ТАК ЖЕ ЭТИ ДОВОДЫ ДОКАЗЫВАЕТ, ЧТО МЫ СТАНДАРТНЫМИ ПРОТОКОЛАМИ ЧЕРЕЗ ЛЭРС МОЖЕМ ОПРАШИВАТЬ ЕК260,270,СПГ741,761.

2) Для работы через ПО "СТЕЛ" и опроса корректоров СПГ741,742, в списке оборудования СТЕЛ-ТУРБО нужно выбрать СПГ741 (742 там просто нет), и опрос идет с обоими корректорами. Настройки СТЕЛ_ТУРБО заключаются в выборе скорости порта и тайм аутов. Вывод из этого, что настройки самого СТЕЛ-ТУРБО НИКАК НЕ МОГУТ ВЛИЯТЬ НА ОПРОС СПГ742, А ДЕЛО В ЗАПРОСЕ САМОГО ПО "СТЕЛ". По этому нельзя утверждать что СТЕЛ-ТУРБО работает с СПГ741 в прозрачном режиме, а с 742 не в прозрачном, (одна и таже настройка) это не логично.

3) Какие у пользователей могут возникнуть вопросы, если это будет драйвер только для опроса СТЕЛ-ТУРБО? Мне кажется их не будет, для этого достаточно просто указать это в названии драйвера.

4) Вы писали что если прибор работает в прозрачном режиме (выше описано доказательство этого) то его добавление не требуется в ЛЭРС. С 4-мя корректорами опрос идет, проблемы только с СПГ742 (по словам "Акцента" это особенность (возможно просто сбой).
Если у вас будет протокол, вы сделаете драйвер для СТЕЛ_ТУРБО указав 01 01 01 01 только для СПГ742 разве в этом есть смысл? (остальные то корректоры работают ,тоже самое можно сделать и сейчас без протокола)

5) Мы проверяли 01 01 01 01 не меняется не при каких настройках корректора, не при разных настройках портов самого СТЕЛ-ТУРБО. Это команда вызова СПГ. Возможно команды FF FF активируют запросы к каким то еще функциям в самом СТЕЛ_ТУРБО (команда установки порта так и начинается), поэтому возможно с СПГ и проблема. ПОВТОРЮСЬ, ЭТИ ЗНАЧЕНИЯ ДЛЯ ДРУГОГО ПРИБОРА ТАКИЕ ЖЕ, ЭТО ПРОВЕРЕННО НА МНОГИХ СТЕЛ_ТУРБО.

6) Мы знаем как работает СТЕЛ_ТУРБО - в прозрачном режиме, и нет никакого переключения между прозрачным и не прозрачным. В подтверждение этого и работа с остальными корректорами и высказывания "СТОРОННЕГО АКЦЕНТА" у которых, повторюсь был протокол, но которым вы отказываетесь верить.

7) Да мы пытаемся получить протокол опроса, но если он и будет, то будет не скоро. В идеале он и совсем не нужен, если будет опрашиваться СПГ742.

8) И мы до сих пор не знаем в чем причина проблемы с СПГ742. СПГ741 с таким же запросом отвечает. В сиутации с ЕК270, ВЫ тоже писали что СТЕЛ-ТУРБО работает не в прозрачном режиме, а потом оказалось проблема в скорости. ПОЭТОМУ МЫ НЕ МОЖЕМ УТВЕРЖДАТЬ НА 100% ЧТО ДЕЛО ИМЕЕНО В 01 01 01 01, ПОКА ВЫ НЕ ПОПРОБУЕТЕ ОПРОСИТЬ ОБЪЕКТЫ С ТАКИМ ЗАПРОСОМ.
Аватара пользователя
Константин Коротких
Разработчик
Разработчик
Сообщения: 6340
Зарегистрирован: 01 сен 2015, 08:29

Re: Ошибка при опросе СПГ741,742, нет ответа от прибора

Сообщение Константин Коротких » 24 ноя 2016, 02:38

Я вам уже неоднократно сообщал, что вам нужно сделать. Вы не выполнили ни одной рекомендации. Мы не можем добавлять, что попало, в драйвера ЛЭРС УЧЕТ и не будем это делать.
Опросите прибор напрямую заводским ПО для СПГ742 и ЛЭРС УЧЕТ, сообщите результат опроса. Только после этого можно будет обдумывать варианты действий.
MAKS18
Сообщения: 400
Зарегистрирован: 17 май 2016, 10:51

Re: Ошибка при опросе СПГ741,742, нет ответа от прибора

Сообщение MAKS18 » 24 ноя 2016, 03:32

Опрос напрямую прологом идет. Это обычный спг 742. Какие еще рекомендации?
Аватара пользователя
Константин Коротких
Разработчик
Разработчик
Сообщения: 6340
Зарегистрирован: 01 сен 2015, 08:29

Re: Ошибка при опросе СПГ741,742, нет ответа от прибора

Сообщение Константин Коротких » 24 ноя 2016, 04:02

ЛЭРС УЧЕТ напрямую опрашивает?
MAKS18
Сообщения: 400
Зарегистрирован: 17 май 2016, 10:51

Re: Ошибка при опросе СПГ741,742, нет ответа от прибора

Сообщение MAKS18 » 24 ноя 2016, 04:38

Константин Коротких писал(а):ЛЭРС УЧЕТ напрямую опрашивает?
Пробовал ЛЭРС ом через ирз атм, думаю разницы никакой, опрашивает.
Аватара пользователя
Константин Коротких
Разработчик
Разработчик
Сообщения: 6340
Зарегистрирован: 01 сен 2015, 08:29

Re: Ошибка при опросе СПГ741,742, нет ответа от прибора

Сообщение Константин Коротких » 24 ноя 2016, 04:44

Через iRZ, это не опрос напрямую. Скажите точно, если опросить ЛЭРС УЧЕТ напрямую, опрос идет?
MAKS18
Сообщения: 400
Зарегистрирован: 17 май 2016, 10:51

Re: Ошибка при опросе СПГ741,742, нет ответа от прибора

Сообщение MAKS18 » 24 ноя 2016, 05:17

Да. Опрос идет.
Аватара пользователя
Константин Коротких
Разработчик
Разработчик
Сообщения: 6340
Зарегистрирован: 01 сен 2015, 08:29

Re: Ошибка при опросе СПГ741,742, нет ответа от прибора

Сообщение Константин Коротких » 24 ноя 2016, 05:41

Опрос идет, следовательно проблема не в СПГ742, а в модеме.
Добавлять код в драйвер СПГ742 мы не будем, поскольку проблема не с ним.
Добавить драйвер для СТЕЛ-Турбо мы не можем, поскольку нет описания протокола обмена (его не предоставляют) и не понятно, что за данные 01 01 01 01. Поддержка такова устройства будет невозможна.
Создавать драйвера типа "Опрос СПГ742 через СТЕЛ-Турбо" мы тоже не будем, поскольку это не корректно, не соответствует архитектуре нашей системы, приведет к возникновению вопросов у пользователей и увеличит нагрузку на службу технической поддержки.
Все что я могу порекомендовать в вашем случае, так это использовать оборудование совместимое с ЛЭРС УЧЕТ.
Я думаю это полный ответ на ваш вопрос. Можно ли закрыть тему?
MAKS18
Сообщения: 400
Зарегистрирован: 17 май 2016, 10:51

Re: Ошибка при опросе СПГ741,742, нет ответа от прибора

Сообщение MAKS18 » 24 ноя 2016, 07:03

Я создал тему о возможности добавление своего драйвер. А. Такая возможность есть. Если мы сами напишем драйвер с исправлениями, вы можете его добавить? И все таки вы можете проверить объекты вставив в опрос 01 01 01 01? Просто чтобы убедиться на 100℅? Насчет закрытия давайте подождем до конца недели.
MAKS18
Сообщения: 400
Зарегистрирован: 17 май 2016, 10:51

Re: Ошибка при опросе СПГ741,742, нет ответа от прибора

Сообщение MAKS18 » 24 ноя 2016, 09:21

Я немного слукавил, у нас было 5 утра и я не опрашивал напрямую через ЛЭРС. Сейчас я опросил, ПРОЛОГОМ ОПРОС ИДЕТ, А ЛЭРСом НЕТ. Журнал приложил.
Вложения
12.xlsx
(10.68 КБ) 8 скачиваний
Аватара пользователя
Константин Коротких
Разработчик
Разработчик
Сообщения: 6340
Зарегистрирован: 01 сен 2015, 08:29

Re: Ошибка при опросе СПГ741,742, нет ответа от прибора

Сообщение Константин Коротких » 24 ноя 2016, 09:28

А почему вы решили, что опрос не идет, хотя по журналу видно, что опрос идет?
MAKS18
Сообщения: 400
Зарегистрирован: 17 май 2016, 10:51

Re: Ошибка при опросе СПГ741,742, нет ответа от прибора

Сообщение MAKS18 » 24 ноя 2016, 09:33

В самом низу видно. Первое с галочкой определение адреса уст-ва.

Неверная длина ответа: получено 276 байт, ожидалось не менее 348 байт. Ошибка опроса устройства СПГ742. Запрос не обработан после 15 попыток
Аватара пользователя
Константин Коротких
Разработчик
Разработчик
Сообщения: 6340
Зарегистрирован: 01 сен 2015, 08:29

Re: Ошибка при опросе СПГ741,742, нет ответа от прибора

Сообщение Константин Коротких » 24 ноя 2016, 10:05

Так это не идет опрос, а идет опрос, но завершается с ошибкой. При опросе через СТЕЛ-Турбо у вас опрос не шел, не удавалось подключиться к прибору.
Это разные ситуации.
В этой теме мы обсуждаем вопрос касательно опроса СПГ742 через СТЕЛ-Турбо.
Если вас интересует, почему вы не можете опросить прибор напрямую, тогда создайте отдельную тему.
MAKS18
Сообщения: 400
Зарегистрирован: 17 май 2016, 10:51

Re: Ошибка при опросе СПГ741,742, нет ответа от прибора

Сообщение MAKS18 » 24 ноя 2016, 13:13

Нашел еще одну информацию (приложу инструкцию настройки ПО стел для СПГ742).
В описание протокола сказано:
Процедура инициализации сеанса начинается с передачи в магистраль стартовой последовательности из 16 байтов 0xFF.
По завершении передачи, перед началом дальнейшего обмена, должен быть выдержан некоторый
таймаут Tstart.
Далее передается запрос сеанса: 0x3F
0х00 0х00 0х00 0х00 [/color]

В 5-м пункте описания протокола сказанно что таймаут Tstart должен быть не менее 3000 мс.

"Значением по-умолчанию является 3000, что для большинства приборов достаточно, но для некоторых прошивок возможно увеличение до 5000 или 6000." Можете попробовать опросить с такой задержкой.

У нас же опрашивается СПГ741 без 01 01 01 01. Может быть тогда с СПГ742 дело как раз в этой задержке, ведь именно здесь у нас и не отвечает прибор.

Возможно в этом руководстве есть еще какая то полезная информация, посмотрите, вам виднее. (В САМОЙ ИНСТРУКЦИИ ЕСТЬ НЕТОЧНОСТИ, МЕСТАМИ УКАЗАН СПГ741, ЭТО ТОЛЬКО ИЗ-ЗА ТОГО, ЧТО РАЗЬЕМЫ RS232 Х2 ОДИНАКОВЫЕ НА 741 И 742)
MAKS18
Сообщения: 400
Зарегистрирован: 17 май 2016, 10:51

Re: Ошибка при опросе СПГ741,742, нет ответа от прибора

Сообщение MAKS18 » 24 ноя 2016, 18:36

Описался.
В 5-м пункте ИНСТРУКЦИИ для настройки ПО СТЕЛ сказано что Tstart должен быть не менее 3000мс.

Еще - длительность таймаута Tstart определяется конкретным типом устройства-абонента и содержится в соответствующих спецификациях. Величина Tstart может быть не меньше, но сколь угодно больше значения, указанного в спецификациях устройства выбранного типа. Для СТЕЛ-ТУРБО от 3000мс и до 6000мс.

Посмотрел опросы ЛЭРС тут это время 1000 мс.

Для корректоров СПГ741,761 такое в инструкциях не сказано(логично что они опрашиваются).

Думаю теперь если вы попробуете, опрос пойдёт. Очень на это надеемся.

(на всякий случай приложу и другие инструкции)
Вложения
Безымянный.png
Безымянный.png (40 КБ) 9823 просмотра
Вычислители.zip
(2.04 МБ) 0 скачиваний
СПГ742 - Настройка СТЕЛ _для пользователей_.pdf
(374.24 КБ) 6 скачиваний
Аватара пользователя
Константин Коротких
Разработчик
Разработчик
Сообщения: 6340
Зарегистрирован: 01 сен 2015, 08:29

Re: Ошибка при опросе СПГ741,742, нет ответа от прибора

Сообщение Константин Коротких » 25 ноя 2016, 03:02

В ЛЭРС УЧЕТ для СПГ742 п оумолчанию используется 1000 мс., однако вы можете установить любое значение тайм-аута. Установить значение тайм-аута вы можете в свойствах Оборудования или нажав кнопку Дополнительно при ручном опросе.
MAKS18
Сообщения: 400
Зарегистрирован: 17 май 2016, 10:51

Re: Ошибка при опросе СПГ741,742, нет ответа от прибора

Сообщение MAKS18 » 25 ноя 2016, 07:07

Меняю таймауты на 3000, 7000, 100 и в настройках спг и при ручном опросе. Причем при ручно опросе еще добавляется 5000мс.

Эти значения отображаются в журнале опроса, но если посмотреть дамп обмена, то там видно что команда 10 01 90 01 00 05 00 3F 00 00 00 00 53 78 идес после FF FF FF .... FF FF всегда через 1000 мс. То есть, не изменяется. В инструкции к СТЕЛу сказано что должно быть не меньше 3000 мс.

Вот дамп:
25.11.2016 6:52:34.572 >> ATD8**********
25.11.2016 6:52:55.008 <<
CONNECT 9
25.11.2016 6:52:55.149 >> FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF
25.11.2016 6:52:56.163 >> 10 01 90 01 00 05 00 3F 00 00 00 00 53 78
25.11.2016 6:53:08.705 >> FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF
25.11.2016 6:53:09.719 >> 10 01 90 01 00 05 00 3F 00 00 00 00 53 78
25.11.2016 6:53:11.576 ----- Порт закрыт -----
25.11.2016 6:54:45.332 ----- Порт открыт -----
25.11.2016 6:54:45.332 >> ATZ

25.11.2016 6:54:45.410 <<
OK

25.11.2016 6:54:45.722 >> ATD8********

25.11.2016 6:55:08.155 <<
CONNECT 9600/R
25.11.2016 6:55:08.264 >> FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF
25.11.2016 6:55:09.278 >> 10 01 90 01 00 05 00 3F 00 00 00 00 53 78
25.11.2016 6:55:15.908 >> FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF
25.11.2016 6:55:16.922 >> 10 01 90 01 00 05 00 3F 00 00 00 00 53 78
25.11.2016 6:55:23.552 >> FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF
25.11.2016 6:55:24.566 >> 10 01 90 01 00 05 00 3F 00 00 00 00 53 78
25.11.2016 6:55:27.265 ----- Порт закрыт -----
25.11.2016 6:55:45.127 ----- Порт открыт -----
25.11.2016 6:55:45.127 >> ATZ

25.11.2016 6:55:45.189 <<
OK

25.11.2016 6:55:45.501 >> ATD********

25.11.2016 6:55:52.069 <<
+CAUSE: 8:17
BUSY

25.11.2016 6:55:52.069 ----- Порт закрыт -----
25.11.2016 6:57:29.179 ----- Порт открыт -----
25.11.2016 6:57:29.179 >> ATZ

25.11.2016 6:57:29.226 <<
OK
25.11.2016 6:57:29.538 >> ATD8*******

25.11.2016 6:57:51.237 <<
CONNECT 9600/RLP

25.11.2016 6:57:51.347 >> FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF
25.11.2016 6:57:52.361 >> 10 01 90 01 00 05 00 3F 00 00 00 00 53 78
25.11.2016 6:58:01.892 >> FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF
25.11.2016 6:58:02.906 >> 10 01 90 01 00 05 00 3F 00 00 00 00 53 78
25.11.2016 6:58:05.543 ----- Порт закрыт -----
25.11.2016 6:58:37.148 ----- Порт открыт -----
25.11.2016 6:58:37.148 >> ATZ

25.11.2016 6:58:37.211 <<
OK

25.11.2016 6:58:37.523 >> ATD8*********

25.11.2016 6:58:58.551 <<
CONNECT 9600/RLP

25.11.2016 6:58:58.661 >> FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF
25.11.2016 6:58:59.675 >> 10 01 90 01 00 05 00 3F 00 00 00 00 53 78
25.11.2016 6:59:10.205 >> FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF
25.11.2016 6:59:11.343 ----- Порт закрыт -----

Везде 1000 мс и не меняется!!! Лэрс последняя версия!

Номер отправил на почту. Можете попробовать опросить поменяв таймаут у себя, чтобы это было видно в дампе?
Аватара пользователя
Константин Коротких
Разработчик
Разработчик
Сообщения: 6340
Зарегистрирован: 01 сен 2015, 08:29

Re: Ошибка при опросе СПГ741,742, нет ответа от прибора

Сообщение Константин Коротких » 25 ноя 2016, 10:07

А вы можете показать скриншот вкладки Основные из Свойств оборудования СПГ742?
MAKS18
Сообщения: 400
Зарегистрирован: 17 май 2016, 10:51

Re: Ошибка при опросе СПГ741,742, нет ответа от прибора

Сообщение MAKS18 » 25 ноя 2016, 10:17

Что вас конкретно интересует?
Вложения
Безымянный.png
Безымянный.png (13.58 КБ) 9793 просмотра
Аватара пользователя
Константин Коротких
Разработчик
Разработчик
Сообщения: 6340
Зарегистрирован: 01 сен 2015, 08:29

Re: Ошибка при опросе СПГ741,742, нет ответа от прибора

Сообщение Константин Коротких » 25 ноя 2016, 10:43

MAKS18 писал(а):Нашел еще одну информацию (приложу инструкцию настройки ПО стел для СПГ742).
В описание протокола сказано:
Процедура инициализации сеанса начинается с передачи в магистраль стартовой последовательности из 16 байтов 0xFF.
По завершении передачи, перед началом дальнейшего обмена, должен быть выдержан некоторый
таймаут Tstart.
Далее передается запрос сеанса: 0x3F
0х00 0х00 0х00 0х00 [/color]

В 5-м пункте описания протокола сказанно что таймаут Tstart должен быть не менее 3000 мс.

"Значением по-умолчанию является 3000, что для большинства приборов достаточно, но для некоторых прошивок возможно увеличение до 5000 или 6000." Можете попробовать опросить с такой задержкой.

У нас же опрашивается СПГ741 без 01 01 01 01. Может быть тогда с СПГ742 дело как раз в этой задержке, ведь именно здесь у нас и не отвечает прибор.

Возможно в этом руководстве есть еще какая то полезная информация, посмотрите, вам виднее. (В САМОЙ ИНСТРУКЦИИ ЕСТЬ НЕТОЧНОСТИ, МЕСТАМИ УКАЗАН СПГ741, ЭТО ТОЛЬКО ИЗ-ЗА ТОГО, ЧТО РАЗЬЕМЫ RS232 Х2 ОДИНАКОВЫЕ НА 741 И 742)
MAKS18 писал(а):Описался.
В 5-м пункте ИНСТРУКЦИИ для настройки ПО СТЕЛ сказано что Tstart должен быть не менее 3000мс.

Еще - длительность таймаута Tstart определяется конкретным типом устройства-абонента и содержится в соответствующих спецификациях. Величина Tstart может быть не меньше, но сколь угодно больше значения, указанного в спецификациях устройства выбранного типа. Для СТЕЛ-ТУРБО от 3000мс и до 6000мс.

Посмотрел опросы ЛЭРС тут это время 1000 мс.

Для корректоров СПГ741,761 такое в инструкциях не сказано(логично что они опрашиваются).

Думаю теперь если вы попробуете, опрос пойдёт. Очень на это надеемся.

(на всякий случай приложу и другие инструкции)
Правильно ли я вас понял, что вот эти данные, вы получили из описания по настройке СТЕЛ-Турбо для работы с СПГ742?
MAKS18
Сообщения: 400
Зарегистрирован: 17 май 2016, 10:51

Re: Ошибка при опросе СПГ741,742, нет ответа от прибора

Сообщение MAKS18 » 25 ноя 2016, 10:50

Да. От 3000 до 6000 мс. Это из инструкции. По поводу Tstart - что он разный для приборов, написано в протоколе м4.Я вам скинул файл спг742- настройка... Это от программы стел инструкция по настройке спг 742 и ПО Стел.
Последний раз редактировалось MAKS18 25 ноя 2016, 10:56, всего редактировалось 1 раз.
Аватара пользователя
Константин Коротких
Разработчик
Разработчик
Сообщения: 6340
Зарегистрирован: 01 сен 2015, 08:29

Re: Ошибка при опросе СПГ741,742, нет ответа от прибора

Сообщение Константин Коротких » 25 ноя 2016, 10:55

Мы проверили опрос с различными задержками (устанавливали задержку 3000 и 6000 мс.), прибор не отвечает. Думаю проблема заключается не в задержке.
Опрос при задержке 6000 мс.

Код: Выделить всё

25.11.2016 17:46:54.982	>>	FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF
25.11.2016 17:47:00.992	>>	10 01 90 01 00 05 00 3F 00 00 00 00 53 78
25.11.2016 17:47:07.569	>>	FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF
25.11.2016 17:47:13.589	>>	10 01 90 01 00 05 00 3F 00 00 00 00 53 78
25.11.2016 17:47:20.149	>>	FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF
25.11.2016 17:47:26.156	>>	10 01 90 01 00 05 00 3F 00 00 00 00 53 78
25.11.2016 17:47:32.727	>>	FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF
25.11.2016 17:47:38.740	>>	10 01 90 01 00 05 00 3F 00 00 00 00 53 78
Кроме того при начале сеанса связи посылается не 16 а 32 байта 0xFF.
MAKS18
Сообщения: 400
Зарегистрирован: 17 май 2016, 10:51

Re: Ошибка при опросе СПГ741,742, нет ответа от прибора

Сообщение MAKS18 » 25 ноя 2016, 11:00

1)А можете проверить еще два варианта, с 4000 мс и без задержки.
2) значит всё-таки в драйвере 742 ошибка, тайм-аут не меняется, вы ее исправить?

На сайте логика есть протокол для спг742 (магистральный протокол м4) это указано именно там.
Аватара пользователя
Константин Коротких
Разработчик
Разработчик
Сообщения: 6340
Зарегистрирован: 01 сен 2015, 08:29

Re: Ошибка при опросе СПГ741,742, нет ответа от прибора

Сообщение Константин Коротких » 25 ноя 2016, 11:09

Мы попробовали с тайм-аутом 4000 мс., опрос так и не пошел.
Более того, попробовали добавить 01 01 01 01 в начало запроса, прибор все равно не отвечает.

Код: Выделить всё

25.11.2016 18:03:40.921	>>	01 01 01 01 FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF
25.11.2016 18:03:45.931	>>	10 01 90 01 00 05 00 3F 00 00 00 00 53 78
25.11.2016 18:03:52.507	>>	01 01 01 01 FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF
25.11.2016 18:03:57.526	>>	10 01 90 01 00 05 00 3F 00 00 00 00 53 78
Без задержки опрос тоже не идет.
MAKS18
Сообщения: 400
Зарегистрирован: 17 май 2016, 10:51

Re: Ошибка при опросе СПГ741,742, нет ответа от прибора

Сообщение MAKS18 » 25 ноя 2016, 11:13

Я до этого на почту сбрасываешь еще два номера. Можете попробовать их? А еще я скидывал скриншоты опроса по стел, может там ответ?
Аватара пользователя
Константин Коротких
Разработчик
Разработчик
Сообщения: 6340
Зарегистрирован: 01 сен 2015, 08:29

Re: Ошибка при опросе СПГ741,742, нет ответа от прибора

Сообщение Константин Коротких » 25 ноя 2016, 11:19

Нам удалось опросить прибор, у него серийный номер 4979.
Опрос прошел при добавлении данных 01 01 01 01 и с задержкой 0 секунд, после первого запроса.
Какой отсюда можно сделать вывод:
Проблема опроса связанна не с задержкой, поскольку мы пробовали её убирать для стандартного запроса. Вся проблема заключается в наличии данных 01 01 01 01.
Запрос с данными 01 01 01 01 и задержкой, почему-то тоже не идет.
MAKS18
Сообщения: 400
Зарегистрирован: 17 май 2016, 10:51

Re: Ошибка при опросе СПГ741,742, нет ответа от прибора

Сообщение MAKS18 » 26 ноя 2016, 20:47

Я опросил другие объекты. Судя по всему для опроса и спг 741 и Спг 742 требуется 01 01 01 01. У вас получилось опросить 742, это отлично. Вы можете сделать драйвер Стел-турбо для 741,742 с запросом 01 01 01 01? Без этого драйвера мы теряем многих возможных клиентов. Странно что ек260.270 опрашиваться без проблем.
Аватара пользователя
Константин Коротких
Разработчик
Разработчик
Сообщения: 6340
Зарегистрирован: 01 сен 2015, 08:29

Re: Ошибка при опросе СПГ741,742, нет ответа от прибора

Сообщение Константин Коротких » 28 ноя 2016, 08:43

Нам необходимо обдумать варианты решения. Результат я сообщу вам немного позже.
Аватара пользователя
Константин Коротких
Разработчик
Разработчик
Сообщения: 6340
Зарегистрирован: 01 сен 2015, 08:29

Re: Ошибка при опросе СПГ741,742, нет ответа от прибора

Сообщение Константин Коротких » 29 ноя 2016, 03:50

К сожалению мы не сможем добавить драйвер СТЕЛ-Турбо поскольку нам не известен его протокол и мы не сможем оказывать его поддержку, если у пользователя возникнут проблемы.
MAKS18
Сообщения: 400
Зарегистрирован: 17 май 2016, 10:51

Re: Ошибка при опросе СПГ741,742, нет ответа от прибора

Сообщение MAKS18 » 29 ноя 2016, 07:31

А если мы сделаем так. Вы сделаете драйвер Стел-турбо под Спг 741.742 с измененным запросом. Я опрошу ~ 100 разных объектов и если проблем не будет, мы его оставим?
Аватара пользователя
Константин Коротких
Разработчик
Разработчик
Сообщения: 6340
Зарегистрирован: 01 сен 2015, 08:29

Re: Ошибка при опросе СПГ741,742, нет ответа от прибора

Сообщение Константин Коротких » 29 ноя 2016, 07:45

Константин Коротких писал(а):К сожалению мы не сможем добавить драйвер СТЕЛ-Турбо поскольку нам не известен его протокол и мы не сможем оказывать его поддержку, если у пользователя возникнут проблемы.
Нет, мы не сможем добавить драйвер.
MAKS18
Сообщения: 400
Зарегистрирован: 17 май 2016, 10:51

Re: Ошибка при опросе СПГ741,742, нет ответа от прибора

Сообщение MAKS18 » 01 дек 2016, 00:09

Смотрите. Делать вы не будете. Значит выход - это сделать его самим. Но если я сделаю драйвер, то как я понимаю(из темы http://forum.lers.ru/viewtopic.php?f=8&t=4465) добавлять его в систему тоже будете вы? То есть в итоге же вы его не добавите? И тогда как быть.Допустим будут те кто его напишет, но как его добавить в систему чтобы им пользовались только мы?
Аватара пользователя
Константин Коротких
Разработчик
Разработчик
Сообщения: 6340
Зарегистрирован: 01 сен 2015, 08:29

Re: Ошибка при опросе СПГ741,742, нет ответа от прибора

Сообщение Константин Коротких » 01 дек 2016, 02:23

Пока механизма по добавлению драйверов пользователей нет. Но когда он появится, то вы сможете добавить драйвер только в свою систему.
MAKS18
Сообщения: 400
Зарегистрирован: 17 май 2016, 10:51

Re: Ошибка при опросе СПГ741,742, нет ответа от прибора

Сообщение MAKS18 » 01 дек 2016, 08:46

На какую версию запланировано добавление этой функции?
Аватара пользователя
Константин Коротких
Разработчик
Разработчик
Сообщения: 6340
Зарегистрирован: 01 сен 2015, 08:29

Re: Ошибка при опросе СПГ741,742, нет ответа от прибора

Сообщение Константин Коротких » 02 дек 2016, 03:59

Точную версию назвать не могу, поскольку эта задача объемная и требует многих изменений в архитектуре системы.
MAKS18
Сообщения: 400
Зарегистрирован: 17 май 2016, 10:51

Re: Ошибка при опросе СПГ741,742, нет ответа от прибора

Сообщение MAKS18 » 08 янв 2017, 16:54

Есть новая информация. Есть два прибора КО404 и Стел-турбо (более новая версия КО404). При опросе ПО "стел" разницы в КО404 и Стел-турбо нет, тоесть в ПО "СТЕЛ" указывается только номер телефона. Я попробовал опрашивать разные приборы и на КО404 и на СТЕл-турбо.

ПО "Стел" опрашивает ТС215 через teleofis wrx700 и КДТ-421Lt (ООО "ТУРБУЛЕНТНОСТЬ ДОН"), они работают по прозрачному протоколу. Так же ПО "СТЕЛ" опрашивает СПГ742,ЕК260,270 через IRZ ATM.
НО при опросе ТС220 через IRZ ATM в ПО "Стел" идет опрос, но данные не сохраняются (ошибка из-за отличия каких то значение) поэтому вопрос:

1) Какая разница может быть между teleofis wrx700 и КДТ-421Lt и IRZ ATM?

(ПО "стел" опрашивает теде приборы что и ЛЭРС, + все приборы с СПГ из списка ниже) [/color]

ЛЭРС ОПРАШИВАЕТ ТОЛЬКО:


ТС215 через teleofis wrx700 и КДТ-421Lt, через КО404 и СТЕЛ-ТУРБО.
ТС220 есть только через СТЕЛ-ТУРБО
ВКГ2 через КДТ-421Lt
корректор БК через СТЕЛ-ТУРБО и КО404
ЕК260,270 через КО404 и СТЕЛ-ТУрБО

То есть и СТЕЛ-ТУРБО и КО404 работают в прозрачном режиме с БК,ЕК260,270, ТС215,220, СПГ761

Проблемы у ЛЭРС через КО404 и СТЕЛ_ТУРБО возникают только с коректорами СПГ:

СПГ741 Стел турбо опрашивает, КО404 - ошибка "неверная контрольная сумма"
СПГ742 Стел-турбо не опрашивается, КО404-"В ответе прибора неверный символ начала пакета"
СПГ761,761.1 опрашивается и через ко404 и через Стел-турбо


2) Получается что это всё таки особенность работы СПГ с оборудованием СТЕЛ-ТУРБО и КО404, остальные корректоры опрашиваются без проблем по прозрачному протоколу(СТЕД_ТУРБО, Ко404 работают в прозрачном режиме иначе как опрашиваются все эти приборы, и приборы через другие модемы. Возможно ли хоть как то решить данный вопрос (добавить 01 01 01 01) и добавить поддержку СТЕЛ-турбо(КО404) и СПГ. ПО "Стел" опрашивает СПГ742 через irz atm с запросом 01 01 01 01 и проблем нет.
MAKS18
Сообщения: 400
Зарегистрирован: 17 май 2016, 10:51

Re: Ошибка при опросе СПГ741,742, нет ответа от прибора

Сообщение MAKS18 » 15 янв 2017, 23:04

up

Есть предположение что команда FF FF FF FF FF FF FF предназначена для каких то внутренних функций (изменение скорости порта, считывание состояния аналоговых или дискретных выходов). Поэтому для опроса СПГ742,741 им пришлось изменить опрос и добавить 01 01 01 01.
Закрыто